Email deliveries may be delayed
Incident Report for GrowthZone
Resolved
This incident has been resolved.
Posted Apr 25, 2023 - 11:20 CDT
Update
We are continuing to monitor for any further issues.
Posted Apr 25, 2023 - 11:20 CDT
Monitoring
Sendgrid has mitigated the issue and is monitoring email traffic for success.
Posted Apr 25, 2023 - 09:59 CDT
Investigating
Our email vendor is currently investigating an issue that is causing delays in email deliverability; You may track their status page using this link https://status.sendgrid.com/
Posted Apr 25, 2023 - 09:44 CDT
This incident affected: GrowthZone (Email Delivery (SendGrid)).