Some users are experiencing system latency in completing some jobs
Incident Report for GrowthZone
Resolved
This incident has been resolved.
Posted Sep 01, 2023 - 15:59 CDT
Monitoring
Due to high usage some customers are experiencing latency in some functionality such as billing. We are aware of the situation and monitoring closely. Our queues are processing and your jobs will be completed. We apologize for this inconvenience and appreciate your patience.
Posted Sep 01, 2023 - 13:15 CDT
This incident affected: GrowthZone (GrowthZone Main Web Application).