The issue causing a delay in sending bulk emails and email previews has been resolved. Thank you for your patience as we worked through this issue.
Posted Jan 06, 2025 - 06:39 CST
Update
We are continuing to to work on a fix for this issue. Another update will be provided as soon as we have more information.
Posted Jan 05, 2025 - 22:34 CST
Update
We are continuing to to work on a fix for this issue. Another update will be provided as soon as we have more information.
Posted Jan 05, 2025 - 08:22 CST
Update
We are continuing to to work on a fix for this issue. Another update will be provided as soon as we have more information.
Posted Jan 04, 2025 - 18:48 CST
Update
We are continuing to work on a fix for this issue.
Posted Jan 04, 2025 - 17:47 CST
Identified
The issue has been identified and a fix is being worked on. We expect that any emails have been processed or queued for delivery will be delivered when the issue has been resolved. We apologize for this delay in your email delivery.
Posted Jan 04, 2025 - 16:41 CST
Investigating
We are currently investigating an issue regarding email deliverability.
Posted Jan 04, 2025 - 15:46 CST
This incident affected: GrowthZone (Email Delivery (SendGrid)).