Scheduled Bill Dates, Payments, and Invoices are displaying as on day early
Incident Report for GrowthZone
Resolved
This incident has been resolved.
Posted May 19, 2022 - 13:30 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 19, 2022 - 12:17 CDT
Investigating
We are currently investigating an issue where schedule bill dates, payments and invoices are displaying as one day early - this is a display issue only, the dates within the database are correct. Updates will be provided within an hour or as soon as available.
Posted May 19, 2022 - 11:37 CDT
This incident affected: GrowthZone (GrowthZone Main Web Application).